• /
  • Log in
  • Free account

CloudWatch billing increase

Problem

After setting up New Relic's Amazon integrations, your usage of the CloudWatch API has increased and subsequently impacted your CloudWatch usage bill.

Solution

For assistance determining which services may cause an increase in billing, contact your New Relic account representative or get support at support.newrelic.com.

Cause

New Relic Infrastructure Amazon integrations leverage CloudWatch to gather metrics. AWS charges joint customers for requests that exceed the first one million per month.

CloudWatch billing issues may be caused by either of the following:

  • Enabling Amazon integrations on several plugins for the same service
  • Adding the incorrect Role ARN to your AWS integrations
Create issueEdit page
Copyright © 2022 New Relic Inc.