問題
New Relic InfrastructureのAmazon統合を設定した後、 CloudWatch APIの使用量が増加し、その結果、 CloudWatchの使用料請求書 に影響が出ています。
解決策
誤ったARNアカウントのインベントリ情報を収集していないか確認してください。インフラストラクチャアカウントに関連付けられたARNが正しいことを確認してください。
ポーリング頻度 は、New Relic がクラウドプロバイダーからデータを収集する頻度を決定します。デフォルトでは、ポーリング頻度は各サービスで利用可能な最大の頻度に設定されています。Amazon CloudWatch の請求書を管理する必要がある場合は、 ポーリング頻度を下げることができます。
New Relic InfrastructureとAmazon AWSとの統合のためのAPI使用方法を確認する。
Go to one.newrelic.com > インフラストラクチャー> AWS> アカウントステータスダッシュボード.
ダッシュボードを確認する。
ダッシュボードには、お客様のアカウントの先月のAmazon AWS APIコールカウントと、先日のCloudWatch APIコール(AWSリソースごと)のチャートが表示されます。この情報は、New Relic の API 使用量のみです。発生する可能性のある他のAWS APIやCloudWatchの使用量は含まれていません。
どのサービスが請求額の増加の原因となるかを判断するには、New Relic のアカウント担当者にお問い合わせいただくか、 support.newrelic.com でサポートを受けてください。
原因
New Relic Infrastructure Amazonの統合では、CloudWatchを活用してメトリクスを収集しています。AWSは、最初の 月間100万件を超えるリクエストに対して、共同利用者に課金します 。
CloudWatchの課金問題は、以下のいずれかが原因と考えられます。
- 同一サービスの複数のプラグインでAmazon統合を可能にする
- 不正な ロール ARN を AWS インテグレーションに追加する。