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本書は、お客様のご参考のために原文の英語版を機械翻訳したものです。

英語版と齟齬がある場合、英語版の定めが優先するものとします。より詳しい情報については、本リンクをご参照ください。

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Amazon AWSの統合におけるメトリックデータの遅延

問題

AWSインテグレーションがAPIリクエストを行ってから、New Relic Infrastructureがメトリックデータを返すまでに遅延が発生する。

解決策

Amazon AWS との連携により、New Relic Infrastructure では、API リクエストと返されるメトリックデータのタイミングに、明示的な遅延または暗黙的な遅延が発生する場合があります。この原因の詳細については、 原因 を参照してください。

通常、遅延は合計されません。明示的な遅延を使用すると、New Relic はメトリックデータが遅延時点のものであることを期待します。たとえば、New Relic が 5 分の明示的な遅延を使用している場合、9 時の時点で最も新鮮なデータポイントは 8:55 のものになるはずです。

ただし、遅延時間はお客様やアカウントによって異なる場合があります。メートル法のデータに異常な遅延が発生した場合。

  1. インフラストラクチャの統合で、メトリックデータのAPIリクエストで 明示的な遅延 または 暗黙的な遅延 が発生しているかどうかを確認します。
  2. CloudWatchユーザー。CloudWatchコンソールに表示されるメトリックデータのスクリーンショットを撮り、 support.newrelic.com にサポートを依頼する際に添付してください。

CloudWatch コンソールのスクリーンショットを使用して、New Relic サポートは、遅延が New Relic Infrastructure で発生しているのか、それとも AWS で直接発生しているのかをトラブルシューティングします。

原因

Amazon AWSとの統合によっては、New Relic Infrastructureに、APIリクエストと返されるメトリックデータのタイミングに、明示的な遅延や暗黙的な遅延が発生する場合があります。

メトリックデータの遅延

コメント

明示的なディレイ

(具体的にはセット)

明示的な遅延とは、より信頼性の高いデータを得るためにNew Relicがコードに設定するものです。AWSへのAPIリクエストではある値が返ってきても、1分後に同じ指標をリクエストすると違う値が返ってくるケースがあります。このような事態が発生する可能性を減らすために、New Relic では明示的な遅延を設定しています。例えば、以下のようなものです。

  • New Relic が 5 分の明示的な遅延を使用している場合、9 時の API コールは 8:50 から 8:55 までのメトリクスを要求します。

  • New Relic が 5 分間の明示的な遅延を使用していない場合、9 時の API 呼び出しは 8:55 から 9:00 までのメトリクスを要求します。

    明示的な遅延は、これらのインフラストラクチャー・アマゾンとの統合から生じる可能性があります。

  • ALB: 5分

  • ELB: 5分

  • CloudFront: 1分

  • RDS: 5分

  • SNS: 10分

インプリシットディレイ

(期待されているが、特に設定されていない)。

暗黙の遅延とは、New Relic が統合の際に経験したパターンです。これらは常に存在するわけではなく、また正確でもありません。

一般的に、暗黙の遅延は、これらのインフラストラクチャAmazonの統合を含む、AWS CloudWatchメトリクスの要求から来る傾向があります。

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